Premier pas sur Cisco avec Dynamips

Premier pas sur Cisco avec Dynamips

Comme vous le savez peut être déjà, je suis administrateur système et réseaux, le problème dans ce job c’est le côté réseau ou je suis très débutant. Je monte quelques solutions de parefeu, de vpn ssl, vpn ipsec mais je suis loin d’être un spécialiste. J’ai donc décider de reprendre les bases et pour cela je travail sur des petites maquettes avec l’outil dynamips.

Dynamips permet de faire tourner des routeurs cisco de manière virtuel (c’est le VMWare de l’admin réseau!). C’est outil est fort pratique pour se monter un petit labo et commencer à bosser !

Mon premier labo

mon premier labo !
mon premier labo !

Comme vous pouvez le voir rien de bien sorcier, 3 routeurs à la file, le but sera de pinguer 2.2.2.2 depuis 1.1.1.1 et inversement.

Nous allons nommer les routeurs de gauches à droites : R1, R2 et R3. Voir ci dessous le nom des différents interfaces et la manière dont elles sont connectées.

interfaces
interfaces

Avec des routes statiques.

Configurations des interfaces.

Sur R1:

Router#conf t

Router(config)#interface f1/1

Router(config-if)#ip address 1.1.1.1 255.255.255.0

Router(config-if)#no sh

Sur R2:

Router#conf t

Router(config)#interface f1/0

Router(config-if)#ip address 1.1.1.2 255.255.255.0

Router(config-if)#no sh

Router(config)#interface f1/1

Router(config-if)#ip address 2.2.2.1 255.255.255.0

Router(config-if)#no sh

Sur R3:

Router#conf t

Router(config)#interface f1/0

Router(config-if)#ip address 2.2.2.2 255.255.255.0

Router(config-if)#no sh

Premier test

on se met sur R1 et on fait un :

Router#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/20 ms

On voit donc que R1 peut bien pinguer R2.

Pour qu’il puisse pinguer R3 nous devons lui ajouter une route.

Router(config)#ip route 2.2.2.0 255.255.255.0 1.1.1.2

Ceci a pour effet d’indiquer à R1 de passer par R2 pour joindre R3.

Router#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/35/40 ms

Router#traceroute 2.2.2.2
Type escape sequence to abort.
Tracing the route to 2.2.2.2
1 1.1.1.2 0 msec 20 msec 4 msec
2 2.2.2.2 28 msec 32 msec *

Avec du routage dynamique (RIP v2)

On supprime les routes statiques

Router(config)#no ip route 2.2.2.0 255.255.255.0 1.1.1.2

Pour supprimer une route, rien de plus simple, il suffit de faire un no de la commande utilisée pour la créer.

On configure le rip sur chaque routeur

Sur R1, R2 et R3 :

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary

Ensuite on déclare les réseaux connues de chacun des routeurs :
Sur R1:

Router(config)#router rip
Router(config-router)#network 1.1.1.0

Sur R2:

Router(config)#router rip
Router(config-router)#network 1.1.1.0
Router(config-router)#network 2.2.2.0

Sur R3:

Router(config)#router rip
Router(config-router)#network 2.2.2.0

La commande show ip route nous montre les routes enregistrées dans le routeur.

Router#show  ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet1/1
2.0.0.0/24 is subnetted, 1 subnets
R       2.2.2.0 [120/1] via 1.1.1.2, 00:00:22, FastEthernet1/1

On peut maintenant tester :

Router#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/35/40 ms

Router#traceroute 2.2.2.2
Type escape sequence to abort.
Tracing the route to 2.2.2.2
1 1.1.1.2 0 msec 20 msec 4 msec
2 2.2.2.2 28 msec 32 msec *

0 Partages

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.